WR 株式会社WR 松戸のホームページ制作・社内システム・IT相談

株式会社WR

千葉県松戸市
松戸・柏・市川・流山・船橋 対応

ホーム›脆弱性情報›jQuery›CVE-2026-106157

警告 CVSS 4.7 jQuery CVE-2026-106157 公表 2026年10月15日

jQueryのKendo UI PanelBarにHTML注入の脆弱性

jQuery — CVE-2026-106157

自分のサイトが該当するか無料診断 → 原文を見る(NVD(米国 脆弱性データベース))↗

どんな問題か

PanelBar で項目URLを表示する際に、文字列の処理が不十分です。攻撃者がURLを操作できると、画面上で悪意あるコードを動かされることがあります。

放置するとどうなるか

表示の改ざんや情報漏えいにつながるおそれがあります。利用者のブラウザ上で不正な操作が実行される可能性があります。

今すぐやること

2026.3.1015 へ更新してください。項目URLを外部データから入れている場合は、制作会社に確認し、修正版を適用してください。

自分のサイトが該当するかの確認手順

  1. お使いのサーバー・プログラムに jQuery が使われているか、制作会社・保守会社・サーバー会社に確認します(管理画面やサーバーのバージョン表示でも分かります)。
  2. バージョンが「2019.2.514 以降、2026.3.1015 未満」に当てはまるか確認します。
  3. 当てはまる場合は、修正版へのアップデートを依頼します。レンタルサーバーの場合はサーバー会社側で対応済みのこともあるので、お知らせを確認してください。
原文(英語)を表示
In Progress® Kendo® UI for jQuery versions starting with 2019.2.514 and prior to 2026.3.1015, the PanelBar component inserts data source item URL values into a single-quoted href attribute without proper encoding. An attacker who can control an item URL can inject additional HTML attributes, including event handlers, and execute JavaScript in a user's browser when the affected item is interacted with. Successful exploitation can compromise the confidentiality and integrity of data accessible to the affected application. This issue is fixed in version 2026.3.1015.

※ 解説は NVD(米国 脆弱性データベース) の公表内容をもとにAIが生成しています。対象バージョン・修正版などの正確な情報は、必ず原文をご確認ください。

無料で相談する →