WR 株式会社WR 松戸のホームページ制作・社内システム・IT相談

株式会社WR

千葉県松戸市
松戸・柏・市川・流山・船橋 対応

ホーム›脆弱性情報›Node.js›CVE-2026-115930

重要 CVSS 7.6 Node.js CVE-2026-115930 公表 2026年10月26日

Node.jsに証明書ストアの問題

Node.js — CVE-2026-115930

自分のサイトが該当するか無料診断 → 原文を見る(NVD(米国 脆弱性データベース))↗

どんな問題か

mongosh が使う Node.js に、信頼する証明書の保存内容に問題があります。古い内容が残っているため、正しくない証明書を信頼してしまうおそれがあります。

放置するとどうなるか

通信相手を正しく確認できず、なりすましの相手と接続してしまう可能性があります。管理画面やデータの安全性に影響するおそれがあります。

今すぐやること

mongosh を 2.14.0 へ更新してください。npm で入れている場合は、ホスト側の Node.js も別途更新が必要です。

自分のサイトが該当するかの確認手順

  1. お使いのサーバー・プログラムに Node.js が使われているか、制作会社・保守会社・サーバー会社に確認します(管理画面やサーバーのバージョン表示でも分かります)。
  2. バージョンが「mongosh versions prior to 2.14.0」に当てはまるか確認します。
  3. 当てはまる場合は、修正版へのアップデートを依頼します。レンタルサーバーの場合はサーバー会社側で対応済みのこともあるので、お知らせを確認してください。
原文(英語)を表示
The MongoDB Shell (mongosh) relies on Node.js as a third-party runtime that carries its own TLS root certificate store. This certificate store has the recoverable eMudhra intermediate CA certificates. This issue impacts MongoDB Shell (mongosh) versions prior to 2.14.0 and can be resolved by updating to mongosh 2.14.0 which bundles Node.js 24.22.1 or later. If mongosh is installed through npm, it uses the Node.js runtime installed on the host; update that runtime separately.

※ 解説は NVD(米国 脆弱性データベース) の公表内容をもとにAIが生成しています。対象バージョン・修正版などの正確な情報は、必ず原文をご確認ください。

無料で相談する →