ホーム›脆弱性情報›WordPressプラグイン›CVE-2026-114422
Enable Media Replace — CVE-2026-114422
どんな問題か
The Enable Media Replace WordPress plugin before 4.2.3 does not restrict the classes allowed when deserializing stored metadata during its media replace-and-update-links routine, allowing unauthenticated users to inject a PHP object that is instantiated when a user with upload access performs a routine media replacement, resulting in PHP Object Injection and local file inclusion of existing PHP/HTML files, which can be escalated to remote code execution where an attacker-influenced PHP or HTML file is present on the server. This is a regression of CVE-2023-4643, which was fixed in 4.1.3 and reintroduced in 4.1.4.
自分のサイトが該当するかの確認手順
- WordPressの管理画面にログインし、左メニュー「プラグイン」(またはテーマ)に Enable Media Replace があるか確認します。
- あれば、バージョン番号を見て「4.2.3 より前」に当てはまるか確認します。
- 当てはまる場合は「更新」ボタンで修正版へ。使っていないプラグインなら削除します。更新ボタンが出ない・怖くて押せない場合は、保守会社か当社へご相談ください。
※ 解説は NVD(米国 脆弱性データベース) の公表内容をもとにAIが生成しています。対象バージョン・修正版などの正確な情報は、必ず原文をご確認ください。