WR 株式会社WR 松戸のホームページ制作・社内システム・IT相談

株式会社WR

千葉県松戸市
松戸・柏・市川・流山・船橋 対応

ホーム›脆弱性情報›WordPressプラグイン›CVE-2026-109414

警告 CVSS 6.5 WordPressプラグイン CVE-2026-109414 公表 2026年10月16日

Vitepos – Point of Sale (POS) for WooCommerce にSQLインジェクションの脆弱性

Vitepos – Point of Sale (POS) for WooCommerce — CVE-2026-109414

自分のサイトが該当するか無料診断 → 原文を見る(NVD(米国 脆弱性データベース))↗

どんな問題か

Vitepos に、検索条件の入力をうまく処理できない問題があります。権限を持つ利用者が細工すると、データベースの情報を不正に読み取られるおそれがあります。

放置するとどうなるか

顧客情報や売上情報など、データベース内の重要情報が漏れるおそれがあります。場合によっては、在庫や取引データの不正操作にもつながります。

今すぐやること

3.6.1 以前を使っている場合は、修正版へ更新してください。3.6.0 からの修正が不十分なため、保守会社に再点検を依頼してください。

自分のサイトが該当するかの確認手順

  1. WordPressの管理画面にログインし、左メニュー「プラグイン」(またはテーマ)に Vitepos – Point of Sale (POS) for WooCommerce があるか確認します。
  2. あれば、バージョン番号を見て「3.6.1 まで」に当てはまるか確認します。
  3. 当てはまる場合は「更新」ボタンで修正版へ。使っていないプラグインなら削除します。更新ボタンが出ない・怖くて押せない場合は、保守会社か当社へご相談ください。
原文(英語)を表示
The Vitepos – Point of Sale (POS) for WooCommerce plugin for WordPress is vulnerable to blind SQL Injection via the 'src_by[].val.start / src_by[].val.end (operator 'bt')' parameter in all versions up to, and including, 3.6.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with vendor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This is an incomplete fix for a previously patched SQL injection (version 3.6.0), which addressed only the gt/lt/le/ge operators while leaving the 'bt' (BETWEEN) operator branch unpatched.

※ 解説は NVD(米国 脆弱性データベース) の公表内容をもとにAIが生成しています。対象バージョン・修正版などの正確な情報は、必ず原文をご確認ください。

無料で相談する →