WR 株式会社WR 松戸のホームページ制作・社内システム・IT相談

株式会社WR

千葉県松戸市
松戸・柏・市川・流山・船橋 対応

ホーム›脆弱性情報›Node.js›CVE-2026-101894

緊急 CVSS 9.1 Node.js CVE-2026-101894 公表 2026年9月28日

decompressに任意ファイル書き込みの脆弱性

Node.js — CVE-2026-101894

自分のサイトが該当するか無料診断 → 原文を見る(NVD(米国 脆弱性データベース))↗

どんな問題か

Node.jsのdecompressに、圧縮ファイルを展開するときの安全確認が不十分な問題があります。細工した圧縮ファイルを使うと、指定外の場所にファイルを書いたり読んだりされるおそれがあります。

放置するとどうなるか

設定ファイルや起動用スクリプトを書き換えられると、サービス停止や不正実行につながる可能性があります。最悪の場合、サーバーを乗っ取られるおそれがあります。

今すぐやること

decompressを10.2.2または11.1.4へ更新してください。未メンテナンス版を使っている場合は、代替パッケージへの移行を検討してください。

自分のサイトが該当するかの確認手順

  1. お使いのサーバー・プログラムに Node.js が使われているか、制作会社・保守会社・サーバー会社に確認します(管理画面やサーバーのバージョン表示でも分かります)。
  2. バージョンが「prior to 10.2.2 and 11.1.4」に当てはまるか確認します。
  3. 当てはまる場合は、修正版へのアップデートを依頼します。レンタルサーバーの場合はサーバー会社側で対応済みのこともあるので、お知らせを確認してください。
原文(英語)を表示
The decompress package for Node.js extracts archives. Prior to 10.2.2 and 11.1.4, the default decompress(input, output) API relies on lexical containment checks that do not account for the kernel following a planted symlink chain. An attacker can supply a crafted archive containing chained symlink entries so that a later entry resolves outside the output directory. This allows files outside output to be read or written, and overwriting startup scripts or configuration can lead to remote code execution. The maintained @xhmikosr/decompress package is fixed in 10.2.2 and 11.1.4, but the separately affected unmaintained decompress package remains unpatched through 4.2.1. This vulnerability results from a bypass of the incomplete hardening for CVE-2026-53486. @xhmikosr/decompress is fixed in versions 10.2.2 and 11.1.4.

※ 解説は NVD(米国 脆弱性データベース) の公表内容をもとにAIが生成しています。対象バージョン・修正版などの正確な情報は、必ず原文をご確認ください。

無料で相談する →